Open issues

Chunter Will not install on 20171212T201254Z

Description

After upgrading smartos to 20171212T201254Z and trying to update chunter via /opt/chunter/bin/update -u or via curl -O http://release.project-fifo.net/gz/rel/chunter-latest.gz && gunzip chunter-latest && bash ./chunter-latest chunter wrongly flags this version of smartos "[a] version is known to be incompatible or faulty.''

This appears to be a issue with how the if statement on line 57 is handled in the GZ. Note the string in
BAD_VERSIONS=2012|2013|2014|2015 from line 7 and the full uname string for the current platform image 20171212T201254Z . In 20171212T201254Z you have 20171212T --> [2012] <-- 54Z which is causing the if to match .

Fix: Change line 57 to something like this

if uname -v |egrep "^2012|2013|2014"

-v will get you just the smartos version string and the carrot will prevent the match on the end part of the version.

Environment

Smartos 20171212T201254Z
Chunter 09.3p15

Status

Assignee

Heinz N. Gies

Reporter

Mark Saad

Labels

None

Components

Affects versions

0.9.2

Priority

Critical